summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjørn Mork <bjorn@mork.no>2017-05-11 12:54:15 +0200
committerBjørn Mork <bjorn@mork.no>2017-05-11 12:54:15 +0200
commit2a51e0c390edb7df9a6fb7ffba971a626b3e993d (patch)
treebea67a69776d8eebea784aa42daf8f3369855791
parent102ada4981f275c58135f5e3383b5a2fb631f64c (diff)
x
-rw-r--r--swi-drivers/Makefile24
1 files changed, 6 insertions, 18 deletions
diff --git a/swi-drivers/Makefile b/swi-drivers/Makefile
index 082a47f..cd2495b 100644
--- a/swi-drivers/Makefile
+++ b/swi-drivers/Makefile
@@ -25,9 +25,6 @@ define KernelPackage/GobiNet
AUTOLOAD:=$(call AutoLoad,50,GobiNet)
endef
-define KernelPackage/GobiNet/install
-endef
-
define KernelPackage/GobiSerial
TITLE:=GobiSerial
SUBMENU:=Other modules
@@ -35,22 +32,13 @@ define KernelPackage/GobiSerial
AUTOLOAD:=$(call AutoLoad,50,GobiSerial)
endef
-define KernelPackage/GobiSerial/install
-endef
-
define Build/Compile
- $(MAKE) $(PKG_JOBS) -C "$(LINUX_DIR)" \
- ARCH="$(LINUX_KARCH)" \
- CROSS_COMPILE="$(TARGET_CROSS)" \
- SUBDIRS="$(PKG_BUILD_DIR)/GobiNet" \
- NOSTDINC_FLAGS="$(NOSTDINC_FLAGS)" \
- modules
- $(MAKE) $(PKG_JOBS) -C "$(LINUX_DIR)" \
- ARCH="$(LINUX_KARCH)" \
- CROSS_COMPILE="$(TARGET_CROSS)" \
- SUBDIRS="$(PKG_BUILD_DIR)/GobiSerial" \
- NOSTDINC_FLAGS="$(NOSTDINC_FLAGS)" \
- modules
+ $(MAKE) $(PKG_JOBS) -C "$(LINUX_DIR)" \
+ ARCH="$(LINUX_KARCH)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ SUBDIRS="$(PKG_BUILD_DIR)/GobiNet" \
+ NOSTDINC_FLAGS="$(NOSTDINC_FLAGS)" \
+ modules
endef
$(eval $(call KernelPackage,GobiNet))