summaryrefslogtreecommitdiff
path: root/swi-drivers/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'swi-drivers/Makefile')
-rw-r--r--swi-drivers/Makefile24
1 files changed, 6 insertions, 18 deletions
diff --git a/swi-drivers/Makefile b/swi-drivers/Makefile
index 082a47f..cd2495b 100644
--- a/swi-drivers/Makefile
+++ b/swi-drivers/Makefile
@@ -25,9 +25,6 @@ define KernelPackage/GobiNet
AUTOLOAD:=$(call AutoLoad,50,GobiNet)
endef
-define KernelPackage/GobiNet/install
-endef
-
define KernelPackage/GobiSerial
TITLE:=GobiSerial
SUBMENU:=Other modules
@@ -35,22 +32,13 @@ define KernelPackage/GobiSerial
AUTOLOAD:=$(call AutoLoad,50,GobiSerial)
endef
-define KernelPackage/GobiSerial/install
-endef
-
define Build/Compile
- $(MAKE) $(PKG_JOBS) -C "$(LINUX_DIR)" \
- ARCH="$(LINUX_KARCH)" \
- CROSS_COMPILE="$(TARGET_CROSS)" \
- SUBDIRS="$(PKG_BUILD_DIR)/GobiNet" \
- NOSTDINC_FLAGS="$(NOSTDINC_FLAGS)" \
- modules
- $(MAKE) $(PKG_JOBS) -C "$(LINUX_DIR)" \
- ARCH="$(LINUX_KARCH)" \
- CROSS_COMPILE="$(TARGET_CROSS)" \
- SUBDIRS="$(PKG_BUILD_DIR)/GobiSerial" \
- NOSTDINC_FLAGS="$(NOSTDINC_FLAGS)" \
- modules
+ $(MAKE) $(PKG_JOBS) -C "$(LINUX_DIR)" \
+ ARCH="$(LINUX_KARCH)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ SUBDIRS="$(PKG_BUILD_DIR)/GobiNet" \
+ NOSTDINC_FLAGS="$(NOSTDINC_FLAGS)" \
+ modules
endef
$(eval $(call KernelPackage,GobiNet))