aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew Lassalle <andrewlassalle@chromium.org>2020-10-27 16:59:41 -0700
committerAleksander Morgado <aleksander@aleksander.es>2020-12-30 14:24:33 +0100
commit4085a2d6b771a40fb637433ed6a05b9d5d4d94b9 (patch)
tree197b2cea0a0fd05d18746aafdf63cd4c6c8d659d /configure.ac
parentf428e0b9f09a4b6aaa921ed84b787df8b7740216 (diff)
qmi-device: add net link management support
This allows us to create and delete net interfaces for qmi devices using netlink. If mux_id is set to QMI_DEVICE_MUX_ID_AUTOMATIC when creating a net interface for `base_ifname`, we search for the lowest N such that `base_ifname.N` is not an available interface, and assign mux_id N+1. If another mux_id is given, then we try to create a net interface using the provided mux_id. This mux ID should be used in the WDS Bind Mux Data Port message.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ed6240a..4053326 100644
--- a/configure.ac
+++ b/configure.ac
@@ -225,7 +225,11 @@ AC_SUBST(QMI_MBIM_QMUX_SUPPORTED)
AM_CONDITIONAL([QMI_MBIM_QMUX_SUPPORTED], [test "x$QMI_MBIM_QMUX_SUPPORTED" = "x1"])
# QRTR support
-AC_CHECK_HEADER(linux/qrtr.h, [have_qrtr=yes], [have_qrtr=no], [])
+have_qrtr="yes"
+AC_CHECK_HEADER(linux/qrtr.h, [], [have_qrtr=no], [])
+AC_CHECK_HEADER(linux/if_link.h, [], [have_qrtr=no], [])
+AC_CHECK_HEADER(linux/netlink.h, [], [have_qrtr=no], [])
+AC_CHECK_HEADER(linux/rtnetlink.h, [], [have_qrtr=no], [])
AC_ARG_ENABLE(qrtr,
AS_HELP_STRING([--enable-qrtr], [Enable support for QRTR protocol [default=no]]),
[enable_qrtr=$enableval],
@@ -237,7 +241,7 @@ fi
if test "x$enable_qrtr" = "xyes"; then
if test "x$have_qrtr" = "xno"; then
- AC_MSG_ERROR([Couldn't find linux/qrtr.h. Install it, or otherwise configure using --disable-qrtr to disable QRTR support.])
+ AC_MSG_ERROR([Couldn't find one of the follwing linux headers (qrtr.h, if_link.h, netlink.h, rtnetlink.h). Install them, or otherwise configure using --disable-qrtr to disable QRTR support.])
fi
AC_DEFINE(QRTR_ENABLED, 1, [Define if QRTR support enabled])
QMI_QRTR_SUPPORTED=1