aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSUZUKI, Shinsuke <suz@kame.net>2007-02-12 08:32:37 +0000
committerBjørn Mork <bjorn@mork.no>2010-08-06 15:37:36 +0200
commitfcdc0798bb2be5fa00427240afda6bdfd3d0a392 (patch)
tree91bfba6e79327c9d092cc45e2d3fc2d1888990eb /configure.in
parented914217eab56d7f17b1ff868aa61def00011a7e (diff)
configure.in, Makefile.in: allows a user to specify the owner/group for the installed files. (suggested by Tsuyoshi MOMOSE and Tomofumi Hayashi)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1a3c59a..825dade 100644
--- a/configure.in
+++ b/configure.in
@@ -202,6 +202,22 @@ if test "$ts_cv_sa_len" = yes; then
AC_DEFINE([HAVE_SA_LEN], 1, [Define to 1 if you have a length field in struct sockaddr])
fi
+dnl configure the ownership of the programs
+AC_MSG_CHECKING(the owner of the programs)
+AC_ARG_WITH(user,
+[ --with-user=USER set the owner of the programs],
+ user="$withval", user="bin")
+AC_MSG_RESULT($user)
+AC_SUBST(user)
+
+dnl configure the group ownership of the programs
+AC_MSG_CHECKING(the group owner of the programs)
+AC_ARG_WITH(group,
+[ --with-group=GROUP set the group owner of the programs],
+ group="$withval", group="bin")
+AC_MSG_RESULT($group)
+AC_SUBST(group)
+
AC_CHECK_HEADERS(stdarg.h)
AC_OUTPUT(Makefile)