aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJeremie Corbier <jeremie.corbier@resel.enst-bretagne.fr>2010-03-25 10:07:03 +0100
committerBjørn Mork <bjorn@mork.no>2010-08-06 15:37:37 +0200
commitaeedae61d12778c4428a7e266913221269480162 (patch)
tree023ce3b78a8d62a129032fc6028d457f5e9199c1 /configure.in
parent2fa86d0c611b69e175c3b07116e9b67b85fe20ef (diff)
102_libc6-2.9-fixes.diff from the Debian package version 20080615-8:
"Fixes for recent libc releases." [ignoring changes to the build generated cftoken.c file] Signed-off-by: Bjørn Mork <bjorn@mork.no>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 59dd84e..6da9af5 100644
--- a/configure.in
+++ b/configure.in
@@ -236,4 +236,11 @@ AC_SUBST(group)
AC_CHECK_HEADERS(stdarg.h)
+AC_MSG_CHECKING(whether libc defines struct in6_pktinfo)
+AC_TRY_COMPILE([#include <netinet/in.h>],
+ [struct in6_pktinfo p6;],
+ [AC_MSG_RESULT(yes)
+ CFLAGS="$CFLAGS -DHAVE_IN6_PKTINFO"],
+ [AC_MSG_RESULT(no)])
+
AC_OUTPUT(Makefile)