aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSUZUKI, Shinsuke <suz@kame.net>2006-05-05 06:00:41 +0000
committerSUZUKI, Shinsuke <suz@kame.net>2006-05-05 06:00:41 +0000
commita5bfb06f21cc1fff3cded6267b18dd3f5d6fe524 (patch)
tree69785762b7fe6512e07aabe2ed8eadbc6dbfe611 /configure.in
parent29d59f550d56e2e70568b6d11db1e4cde5ed4ceb (diff)
- updated the list of the supported RFCs
- NTP option number has been already assigned by IANA - added other official option numbers for future implementors
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 5e8775b..edf4f0e 100644
--- a/configure.in
+++ b/configure.in
@@ -207,18 +207,20 @@ else
AC_MSG_RESULT(no)
fi
-dnl DHCP option type values not officially defined
AC_MSG_CHECKING(for DHCP NTP option)
AC_ARG_WITH(opt-ntp,
[ --with-opt-ntp=VALUE specify DHCP option value for NTP],
dhcpopt_ntp="$withval", dhcpopt_ntp=0)
-if test $dhcpopt_ntp = 0 ; then
- dhcpopt_ntp=-1
- AC_MSG_RESULT(unspecified)
-else
+if test $dhcpopt_ntp != 0 ; then
AC_MSG_RESULT(using $dhcpopt_ntp)
+ DH6OPT_NTP="-DDH6OPT_NTP=$dhcpopt_ntp"
+ AC_SUBST(DH6OPT_NTP)
+else
+ AC_MSG_RESULT(no)
fi
-AC_SUBST(dhcpopt_ntp)
+
+dnl DHCP option type values not officially defined
+dnl (no such option now)
AC_CHECK_HEADERS(stdarg.h)