summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-05-26 16:31:50 +0200
committerFelix Fietkau <nbd@openwrt.org>2013-05-26 16:31:50 +0200
commita1545f995346f16f3df657b5f494c699890bd1f4 (patch)
treed17073b6397de0c00859fc9bd6bb2af778fc3b4c /CMakeLists.txt
initial dummy
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..17914a7
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,20 @@
+cmake_minimum_required(VERSION 2.6)
+
+PROJECT(usbmode C)
+ADD_DEFINITIONS(-Os -ggdb -Wall -Werror --std=gnu99 -Wmissing-declarations)
+
+SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
+
+SET(SOURCES main.c)
+SET(LIBS ubox blobmsg_json)
+
+IF(DEBUG)
+ ADD_DEFINITIONS(-DDEBUG -g3)
+ENDIF()
+
+ADD_EXECUTABLE(usbmode ${SOURCES})
+TARGET_LINK_LIBRARIES(usbmode ${LIBS})
+
+INSTALL(TARGETS usbmode
+ RUNTIME DESTINATION sbin
+)