summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjørn Mork <bjorn@mork.no>2016-03-30 17:28:18 +0200
committerBjørn Mork <bjorn@mork.no>2016-03-30 17:28:18 +0200
commita2eaa452b7e95624cb9f83f1ff7c60c31a138a97 (patch)
tree18ea4fa25139f9b6b6e44fc3e24c1a63682300f5
parentbe4df1b8efaf8acdc842b7b1d1251eca89a63a45 (diff)
conserver: adding first package skeleton
Signed-off-by: Bjørn Mork <bjorn@mork.no>
-rw-r--r--conserver/Makefile61
-rw-r--r--conserver/patches/001-remove-strip.patch48
2 files changed, 109 insertions, 0 deletions
diff --git a/conserver/Makefile b/conserver/Makefile
new file mode 100644
index 0000000..7e41618
--- /dev/null
+++ b/conserver/Makefile
@@ -0,0 +1,61 @@
+#
+# Copyright (C) 2016 Bjørn Mork <bjorn@mork.no>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=conserver
+PKG_VERSION:=8.2.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.conserver.com/
+PKG_MD5SUM:=44dd9109e59bccc4c9942648fc05481a
+
+PKG_LICENSE:=BSD
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/conserver
+ SECTION:=admin
+ CATEGORY:=Administration
+ TITLE:=Connect multiple user to a serial console with logging
+ URL:=http://www.conserver.com/
+ MAINTAINER:=Bjørn Mork <bjorn@mork.no>
+endef
+
+define Package/conserver/description
+ Conserver is an application that allows multiple users to watch a
+ serial console at the same time. It can log the data, allows users
+ to take write-access of a console (one at a time), and has a
+ variety of bells and whistles to accentuate that basic
+ functionality. The idea is that conserver will log all your serial
+ traffic so you can go back and review why something crashed, look
+ at changes (if done on the console), or tie the console logs into a
+ monitoring system (just watch the logfiles it creates). With
+ multi-user capabilities you can work on equipment with others,
+ mentor, train, etc. It also does all that client-server stuff so
+ that, assuming you have a network connection, you can interact with
+ any of the equipment from home or wherever.
+endef
+
+define Package/conserver/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/conserver $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/console $(1)/usr/bin/
+ $(INSTALL_DIR) $(1)/etc/conserver
+ $(CP) $(PKG_INSTALL_DIR)/usr/share/examples/conserver/conserver.cf $(1)/etc/conserver/
+ $(CP) $(PKG_INSTALL_DIR)/usr/share/examples/conserver/conserver.passwd $(1)/etc/conserver/
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/share/examples/conserver/conserver.rc $(1)/etc/init.d/conserver
+endef
+
+$(eval $(call BuildPackage,conserver))
diff --git a/conserver/patches/001-remove-strip.patch b/conserver/patches/001-remove-strip.patch
new file mode 100644
index 0000000..9271c51
--- /dev/null
+++ b/conserver/patches/001-remove-strip.patch
@@ -0,0 +1,48 @@
+diff -ur conserver-8.2.1.old/autologin/Makefile.in conserver-8.2.1/autologin/Makefile.in
+--- conserver-8.2.1.old/autologin/Makefile.in 2013-09-14 00:46:49.000000000 +0200
++++ conserver-8.2.1/autologin/Makefile.in 2016-03-30 17:11:44.489446435 +0200
+@@ -9,7 +9,7 @@
+
+ ### Installation programs and flags
+ INSTALL = @INSTALL@
+-INSTALL_PROGRAM = @INSTALL_PROGRAM@ -s
++INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ LN_S = @LN_S@
+ MKDIR = @MKDIR@
+
+diff -ur conserver-8.2.1.old/conserver/Makefile.in conserver-8.2.1/conserver/Makefile.in
+--- conserver-8.2.1.old/conserver/Makefile.in 2013-09-14 00:46:53.000000000 +0200
++++ conserver-8.2.1/conserver/Makefile.in 2016-03-30 17:11:44.509446803 +0200
+@@ -14,7 +14,7 @@
+
+ ### Installation programs and flags
+ INSTALL = @INSTALL@
+-INSTALL_PROGRAM = @INSTALL_PROGRAM@ -s
++INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ LN_S = @LN_S@
+ MKDIR = @MKDIR@
+
+diff -ur conserver-8.2.1.old/console/Makefile.in conserver-8.2.1/console/Makefile.in
+--- conserver-8.2.1.old/console/Makefile.in 2013-09-14 00:46:55.000000000 +0200
++++ conserver-8.2.1/console/Makefile.in 2016-03-30 17:11:44.481446288 +0200
+@@ -10,7 +10,7 @@
+
+ ### Installation programs and flags
+ INSTALL = @INSTALL@
+-INSTALL_PROGRAM = @INSTALL_PROGRAM@ -s
++INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ LN_S = @LN_S@
+ MKDIR = @MKDIR@
+
+diff -ur conserver-8.2.1.old/contrib/chat/Makefile.in conserver-8.2.1/contrib/chat/Makefile.in
+--- conserver-8.2.1.old/contrib/chat/Makefile.in 2013-09-14 00:47:31.000000000 +0200
++++ conserver-8.2.1/contrib/chat/Makefile.in 2016-03-30 17:11:44.501446656 +0200
+@@ -10,7 +10,7 @@
+
+ ### Installation programs and flags
+ INSTALL = @INSTALL@
+-INSTALL_PROGRAM = @INSTALL_PROGRAM@ -s
++INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ LN_S = @LN_S@
+ MKDIR = @MKDIR@
+