aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..928d926
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,27 @@
+#
+# automake adds dependencies that we don't like, so we explicitly remove them
+#
+Makefile:
+
+#
+# We have a lot of files that we want shipped with the distribution.
+#
+EXTRA_DIST = RELNOTES LICENSE \
+ contrib/3.0b1-lease-convert contrib/dhclient-tz-exithook.sh \
+ contrib/dhcp.spec contrib/sethostname.sh contrib/solaris.init \
+ contrib/ms2isc/Registry.pm contrib/ms2isc/ms2isc.pl \
+ contrib/ms2isc/readme.txt contrib/ldap/dhcpd-conf-to-ldap \
+ contrib/ldap/dhcp.schema contrib/ldap/README.ldap \
+ doc/IANA-arp-parameters doc/Makefile doc/References.html \
+ doc/References.txt doc/References.xml doc/api+protocol \
+ doc/ja_JP.eucJP/dhclient-script.8 doc/ja_JP.eucJP/dhclient.8 \
+ doc/ja_JP.eucJP/dhclient.conf.5 doc/ja_JP.eucJP/dhclient.leases.5 \
+ doc/ja_JP.eucJP/dhcp-eval.5 doc/ja_JP.eucJP/dhcp-options.5 \
+ doc/examples/dhclient-dhcpv6.conf doc/examples/dhcpd-dhcpv6.conf \
+ util/bindvar.sh \
+ bind/Makefile bind/bind.tar.gz bind/version.tmp
+
+SUBDIRS = bind includes tests common dst omapip client dhcpctl relay server
+
+nobase_include_HEADERS = dhcpctl/dhcpctl.h
+