summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 98d7d75..5c41098 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,20 +12,17 @@ SET(SOURCES main.c dev.c commands.c qmi-message.c mbim.c)
FIND_PATH(ubox_include_dir libubox/usock.h)
FIND_PATH(blobmsg_json_include_dir libubox/blobmsg_json.h)
-FIND_PATH(json_include_dir json-c/json.h json/json.h json.h)
-INCLUDE_DIRECTORIES(${ubox_include_dir} ${blobmsg_json_include_dir} ${json_include_dir})
+INCLUDE_DIRECTORIES(${ubox_include_dir} ${blobmsg_json_include_dir})
IF(BUILD_STATIC)
- FIND_LIBRARY(json_library NAMES libjson.a libjson-c.a)
FIND_LIBRARY(blobmsg_json_library NAMES libblobmsg_json.a)
FIND_LIBRARY(ubox_library NAMES libubox.a)
ELSE(BUILD_STATIC)
- FIND_LIBRARY(json_library NAMES json-c json)
FIND_LIBRARY(blobmsg_json_library NAMES blobmsg_json)
FIND_LIBRARY(ubox_library NAMES ubox)
ENDIF(BUILD_STATIC)
-SET(LIBS ${ubox_library} ${blobmsg_json_library} ${json_library})
+SET(LIBS ${ubox_library} ${blobmsg_json_library})
IF(DEBUG_PACKET)
ADD_DEFINITIONS(-DDEBUG_PACKET)