summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjørn Mork <bjorn@mork.no>2017-05-16 14:37:24 +0200
committerBjørn Mork <bjorn@mork.no>2017-05-16 14:37:24 +0200
commit1b94962aaec5ca60d26aa18a7148c39dc44e4e89 (patch)
tree090f5d159338c2c2bea2be92059c22f58b1c210b
parent5bf493eda145f53c1e4f62b0c70f6d7545308759 (diff)
iotop: add
Signed-off-by: Bjørn Mork <bjorn@mork.no>
-rw-r--r--iotop/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/iotop/Makefile b/iotop/Makefile
new file mode 100644
index 0000000..0b27fea
--- /dev/null
+++ b/iotop/Makefile
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2017 Bjørn Mork <bjorn@mork.no>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=iotop
+PKG_VERSION:=0.6
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Bjørn Mork <bjorn@mork.no>
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://guichaz.free.fr/iotop/files/
+PKG_MD5SUM:=080fbb494566b5291a2a27cf6c203562
+
+PKG_LICENSE:=GPL-2.0+
+PKG_LICENSE_FILES:=COPYING
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+
+define Package/iotop
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Simple top-like I/O monitor
+ URL:=http://guichaz.free.fr/iotop/
+ DEPENDS:=+python
+endef
+
+define Package/iotop/description
+ iotop does for I/O usage what top(1) does for CPU usage. It watches I/O
+ usage information output by the Linux kernel and displays a table of
+ current I/O usage by processes on the system. It is handy for answering
+ the question "Why is the disk churning so much?".
+endef
+
+define Build/Compile
+ $(call Build/Compile/PyMod,,\
+ install --prefix=/usr --root="$(PKG_INSTALL_DIR)" \
+ )
+endef
+
+$(eval $(call PyPackage,iotop))
+$(eval $(call BuildPackage,iotop))